It seems that this is best pushed somewhere else. I.e. next to the `wrap-code' functions. Looks like there's plenty of room for simplification once the stack-oriented label juggling is pushed deeper. Especially the org code is a bit of a hack. It probably also just works using dummy names. Maybe `wrap-word' and `wrap-variable' should have an optional org argument?