How hard would it be to change `macro' to `gen' or something similar, to distinguish from scheme macros? Can it be called `code'? Maybe that's too general. Let's just keep it like it is. The change is cross-cutting and there doesn't seem to be a single right pick.