Sun May 18 17:11:49 CEST 2008

delimited control again

Now.. hold that thought. Maybe it is better to introduce a proper
nesting structure to get at macro code..

  * 'reset' needs to be a macro
  * 'shift' can be plain code

what about making reset ']' and put the logic of shift in the
balancing word? i.e. for[ 1 2 ]

Maybe it's best to return to shift/reset from semantics point, and not
from the particular implementation scat->scheme i'm using.