[<<][pool][>>][..]
Tue Nov 15 11:13:22 EST 2011

Bad usb mouse?

Today it happened again, 3rd time.  A bunch of messages like this:

[447148.796228] usb 7-4: new low speed USB device using ohci_hcd and address 18
[447148.975254] usb 7-4: New USB device found, idVendor=045e, idProduct=0040
[447148.975257] usb 7-4: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[447148.975259] usb 7-4: Product: Microsoft Wheel Mouse OpticalĀ®
[447148.975261] usb 7-4: Manufacturer: Microsoft
[447148.986330] input: Microsoft Microsoft Wheel Mouse OpticalĀ® as /class/input/input87
[447148.986430] generic-usb 0003:045E:0040.005C: input,hidraw2: USB HID v1.00 Mouse [Microsoft Microsoft Wheel Mouse OpticalĀ®] on usb-0000:00:16.0-4/input0
[447285.281594] hub 7-0:1.0: port 4 disabled by hub (EMI?), re-enabling...
[447285.281599] usb 7-4: USB disconnect, address 18


Then finally a bunch of messages like this:

[492961.136499] INFO: task khubd:266 blocked for more than 120 seconds.
[492961.136502] "echo 0 > /proc/sys/kernel/hung_task_timeout_secs" disables this message.
[492961.136504] khubd         D 0000000000000000     0   266      2 0x00000000
[492961.136508]  ffffffff8142d020 0000000000000046 0000000000000000 0000000000000246
[492961.136511]  ffff88019f14ec70 00000000ffffffff 000000010756b8e9 000000000000b188
[492961.136514]  0000000000000000 0000000000000000 ffffffff81460c50 ffff88019f15dfd8
[492961.136517] Call Trace:
[492961.136523]  [<ffffffff812ecb15>] ? schedule+0x16/0x2a
[492961.136526]  [<ffffffff8120d3b5>] ? usb_kill_urb+0xa1/0xbd
[492961.136530]  [<ffffffff810574a0>] ? autoremove_wake_function+0x0/0x2a
[492961.136533]  [<ffffffff8120e7a8>] ? usb_start_wait_urb+0x80/0xbf
[492961.136537]  [<ffffffff8120ea6f>] ? usb_control_msg+0x14b/0x172
[492961.136540]  [<ffffffff8117d519>] ? kref_put+0x41/0x4a
[492961.136543]  [<ffffffff810d633f>] ? _slab_irq_disable+0x37/0x58
[492961.136546]  [<ffffffff8120fc38>] ? usb_get_descriptor+0x6d/0x9e
[492961.136549]  [<ffffffff812116ca>] ? usb_get_configuration+0x22e/0x15f4
[492961.136552]  [<ffffffff812ee201>] ? rt_spin_lock+0x29/0x6d
[492961.136555]  [<ffffffff8120fd54>] ? usb_get_device_descriptor+0xeb/0xfb
[492961.136557]  [<ffffffff810d73d0>] ? kfree+0x122/0x16e
[492961.136560]  [<ffffffff8120fd54>] ? usb_get_device_descriptor+0xeb/0xfb
[492961.136563]  [<ffffffff812087eb>] ? hub_port_init+0x6df/0x702
[492961.136565]  [<ffffffff81208fff>] ? usb_enumerate_device+0x16/0xe5
[492961.136567]  [<ffffffff8120934a>] ? usb_new_device+0x2b/0x193
[492961.136570]  [<ffffffff8120ab45>] ? hub_thread+0xa65/0xfa8
[492961.136573]  [<ffffffff810574a0>] ? autoremove_wake_function+0x0/0x2a
[492961.136575]  [<ffffffff8120a0e0>] ? hub_thread+0x0/0xfa8
[492961.136578]  [<ffffffff8105711c>] ? kthread+0x75/0x7d
[492961.136581]  [<ffffffff810321c4>] ? finish_task_switch+0x49/0xe0
[492961.136584]  [<ffffffff81003924>] ? kernel_thread_helper+0x4/0x10
[492961.136586]  [<ffffffff810570a7>] ? kthread+0x0/0x7d
[492961.136589]  [<ffffffff81003920>] ? kernel_thread_helper+0x0/0x10
[493081.136512] INFO: task khubd:266 blocked for more than 120 seconds.


lsusb also hangs.  Rebooting solves it for a while.  Maybe the mouse
fell on the floor one time too many?  Though that shouldn't really
cause system to lock up like this..  Something wrong with my USB hub
on the motherboard?




[Reply][About]
[<<][pool][>>][..]