[<<][pool][>>][..]
Fri Feb 4 17:06:59 EST 2011

Wacom Bamboo Pen

Good news is that it seems to be supported [1].


sudo apt-get install dkms
download and install [2].

There's a problem with the kernel API though:



DKMS make.log for wacom-0.8.8 for kernel 2.6.33.7-rt29 (amd64)
Fri Feb  4 17:04:59 EST 2011
    Building linuxwacom drivers for 2.6 kernel.
***Note: Drivers not enabled as modules in your kernel config but requested through configure are NOT built
make -C /lib/modules/2.6.33.7-rt29/build M=/var/lib/dkms/wacom/0.8.8/build/src/2.6.30
make[1]: Entering directory `/opt/src/linux-2.6.33.7-rt29'
  LD      /var/lib/dkms/wacom/0.8.8/build/src/2.6.30/built-in.o
  CC [M]  /var/lib/dkms/wacom/0.8.8/build/src/2.6.30/wacom_wac.o
  CC [M]  /var/lib/dkms/wacom/0.8.8/build/src/2.6.30/wacom_sys.o
/var/lib/dkms/wacom/0.8.8/build/src/2.6.30/wacom_sys.c: In function ‘wacom_probe’:
/var/lib/dkms/wacom/0.8.8/build/src/2.6.30/wacom_sys.c:490: error: implicit declaration of function ‘usb_alloc_coherent’
/var/lib/dkms/wacom/0.8.8/build/src/2.6.30/wacom_sys.c:491: warning: assignment makes pointer from integer without a cast
/var/lib/dkms/wacom/0.8.8/build/src/2.6.30/wacom_sys.c:561: error: implicit declaration of function ‘usb_free_coherent’
make[2]: *** [/var/lib/dkms/wacom/0.8.8/build/src/2.6.30/wacom_sys.o] Error 1
make[1]: *** [_module_/var/lib/dkms/wacom/0.8.8/build/src/2.6.30] Error 2
make[1]: Leaving directory `/opt/src/linux-2.6.33.7-rt29'
make: *** [all] Error 2


[1] http://frankgroeneveld.nl/2010/04/11/get-wacom-bamboo-fun-pen-working-in-ubuntu-lucid/
[2] http://ppa.launchpad.net/doctormo/wacom-plus/ubuntu/pool/main/w/wacom-source/wacom-dkms_0.8.8-1ubuntu5_all.deb





[Reply][About]
[<<][pool][>>][..]