[<<][pool][>>][..]
Fri Apr 11 17:27:11 EDT 2008

burning dvds


EDIT: just burning speed, using -speed=1 it works fine,
see http://zwizwa.be/darcs/pool/bin/dvd


data dvds no problem. multisession ok too. but video, i can't seem to
get right..

tom@del:~/bin$ dvd video /pub/dey.iso
Executing 'builtin_dd if=/pub/dey.iso of=/dev/scd0 obs=32k seek=0'
/dev/scd0: "Current Write Speed" is 3.3x1352KBps.
          0/166002688 ( 0.0%) @0x, remaining ??:?? RBU 100.0% UBU   0.0%
          0/166002688 ( 0.0%) @0x, remaining ??:?? RBU 100.0% UBU   0.0%
          0/166002688 ( 0.0%) @0x, remaining ??:?? RBU 100.0% UBU   0.0%
          0/166002688 ( 0.0%) @0x, remaining ??:?? RBU 100.0% UBU   0.0%
          0/166002688 ( 0.0%) @0x, remaining ??:?? RBU 100.0% UBU   0.0%
          0/166002688 ( 0.0%) @0x, remaining ??:?? RBU 100.0% UBU   0.0%
          0/166002688 ( 0.0%) @0x, remaining ??:?? RBU 100.0% UBU   0.0%
          0/166002688 ( 0.0%) @0x, remaining ??:?? RBU 100.0% UBU   0.0%
          0/166002688 ( 0.0%) @0x, remaining ??:?? RBU 100.0% UBU   0.0%
          0/166002688 ( 0.0%) @0x, remaining ??:?? RBU 100.0% UBU   0.0%
          0/166002688 ( 0.0%) @0x, remaining ??:?? RBU 100.0% UBU   0.0%
          0/166002688 ( 0.0%) @0x, remaining ??:?? RBU 100.0% UBU   0.0%
          0/166002688 ( 0.0%) @0x, remaining ??:?? RBU 100.0% UBU   0.0%
          0/166002688 ( 0.0%) @0x, remaining ??:?? RBU 100.0% UBU   0.0%
          0/166002688 ( 0.0%) @0x, remaining ??:?? RBU 100.0% UBU   0.0%
          0/166002688 ( 0.0%) @0x, remaining ??:?? RBU 100.0% UBU   0.0%
          0/166002688 ( 0.0%) @0x, remaining ??:?? RBU 100.0% UBU   0.0%
          0/166002688 ( 0.0%) @0x, remaining ??:?? RBU 100.0% UBU   0.0%
          0/166002688 ( 0.0%) @0x, remaining ??:?? RBU 100.0% UBU   0.0%
          0/166002688 ( 0.0%) @0x, remaining ??:?? RBU 100.0% UBU   0.0%
:-[ WRITE@LBA=0h failed with SK=0h/ASC=00h/ACQ=02h]: Input/output error
:-( write failed: Input/output error
tom@del:~/bin$


don't know what that's about.. the script:

#!/bin/bash

#
# Note: the pathspec does not have the semantics of unix 'cp'.
#
#       * FILE: placed in the root directory.
#       * DIRECTORY: the CONTENTS are placed in the root directory.
#
# To copy a directory, you need to move the root dir.
#
#   dvd init|add -root dirname dirname
#

usage () {
    echo "usage:"
    echo "    `basename $0` init|add [options ...] <pathspec> [pathspec ...]"
    echo "    `basename $0` video    [options ...] <video.img>"
}

[ -z "$2" ] && usage && exit 1




unset SUDO_COMMAND
export MKISOFS=/usr/bin/mkisofs

CMD=$1
shift

DEV=/dev/scd0
ARGS="$DEV -speed=1 -r -J"

add () {
    growisofs -M $ARGS "$@"
}
init () {
    growisofs -Z $ARGS "$@"
}
video () {
    growisofs -dvd-compat -Z $DEV=$1
}


$CMD "$@"



[Reply][About]
[<<][pool][>>][..]