[<<][openwrt][>>][..]
Tue Nov 12 13:02:26 EST 2013

Installing packages on a self-compiled base image

root@portage:/etc# opkg install openvpn-openssl
Installing openvpn-openssl (2.3.2-3) to root...
Downloading http://downloads.openwrt.org/snapshots/trunk/brcm47xx/packages/openvpn-openssl_2.3.2-3_brcm47xx.ipk.
Collected errors:
 * satisfy_dependencies_for: Cannot satisfy the following dependencies for openvpn-openssl:
 *      kernel (= 3.10.18-1-a352f846a01e01046a29af4f5d304b86) * 
 * opkg_install_cmd: Cannot install package openvpn-openssl.


IIRC there is a way to disable this dependency checking.

Switched to attitude_adjustment repo.
How to override?

opkg install --force-depends 

I'm guessing that installing older packages should work, and that
installing newer packages might introduce problems with the older
core.

Looks like openvpn needs kmod-tun and I didn't put that in there.
It's not worth the trouble really.
Better to get a supported router.

EDIT: Let's try to compile the package using the openwrt build.  I
still have it in /opt/xc/openwrt/belkin.20130903/trunk

[master] tom@zoo:/opt/xc/openwrt/belkin.20130903/trunk/bin/brcm47xx/packages$ ls -l kmod-tun_3.6.11-1_brcm47xx.ipk 
-rw-r--r-- 1 tom tom 11015 Nov 12 13:27 kmod-tun_3.6.11-1_brcm47xx.ipk

I put them here:
http://zwizwa.be/openwrt/belkin.20130903/packages

This still needs --force-depends, but at least tun.ko loads.

Also, the kmod-tun from attitude adjustment seems to be ignored since mine is newer?



[Reply][About]
[<<][openwrt][>>][..]