[<<][openwrt][>>][..]
Sat Jun 23 14:25:43 EDT 2012

OpenWRT packages

So what pre-compiled packages can be installed on this kernel?
http://www.jianyu.net/openwrt/build_29617/brcm4716/packages/

Maybe best to just build them myself and set up a local archive.  Some
questions:

- I don't see openvpn; how to get it?
See script/feeds below

- Do all packages show up in the .trx?

Nope, see legend in make menuconfig:
 [*] built-in  [ ] excluded  <M> package  < > package capable

- What config file should I save?
.coinfig
I don't know where the kernel config goes..


./scripts/feeds update
...
./scripts/feeds install openvpn
Installing package 'openvpn'
Installing package 'lzo'
./scripts/feeds install asterisk18
Installing package 'asterisk-1.8.x'
Installing package 'popt'
Installing package 'iksemel'
Installing package 'gnutls'
Installing package 'libgcrypt'
Installing package 'libgpg-error'
Installing package 'libtasn1'
Installing package 'bluez-libs'
Installing package 'spandsp'
Installing package 'tiff'
Installing package 'jpeg'
Installing package 'gettext'
Installing package 'libiconv'
WARNING: No feed for package 'uclibcxx' found, maybe it's already part of the standard packages?
Installing package 'curl'
Installing package 'mysql'
WARNING: No feed for package 'uclibcxx' found, maybe it's already part of the standard packages?
WARNING: No feed for package 'uclibcxx' found, maybe it's already part of the standard packages?

Trying to compile selecting only openwrt and asterisk18 this gives
WARNINGs and eventually an error.  Looks like dependencies need to be
enabled explicitly.  Let's try just openvpn, lzo for now.  Hmmm.. upon
inspecition lzo was selected..

[master] tom@zoo:/opt/xc/openwrt/belkin/trunk$ make V=99 2>&1 |grep WARNING
WARNING: skipping libssp -- package not selected
WARNING: skipping libstdcpp -- package not selected
WARNING: skipping librt -- package not selected
WARNING: skipping libgfortran -- package not selected
WARNING: skipping ldd -- package not selected
WARNING: skipping ldconfig -- package not selected
WARNING: skipping libiw -- package not selected
WARNING: modpost: missing MODULE_LICENSE() in /opt/xc/openwrt/belkin/trunk/build_dir/linux-brcm4716/broadcom-wl-5.10.56.27.3/driver/wl.o
WARNING: modpost: missing MODULE_LICENSE() in /opt/xc/openwrt/belkin/trunk/build_dir/linux-brcm4716/broadcom-wl-5.10.56.27.3/driver-mini/wl.o
WARNING: skipping kmod-brcm-wl-mini -- package not selected
WARNING: skipping dropbearconvert -- package not selected
WARNING: skipping bluez-libs -- package not selected
WARNING: skipping openssl-util -- package not selected
WARNING: skipping curl -- package not selected
WARNING: skipping libcurl -- package not selected
WARNING: skipping libgpg-error -- package not selected
WARNING: skipping libgcrypt -- package not selected

I had to force install of the module package:

opkg install --force-depends kmod-tun_3.0.18-1_brcm4716.ipk 


[Reply][About]
[<<][openwrt][>>][..]