[<<][nixos][>>][..]
Fri Nov 10 21:47:31 EST 2017

Emacs with packages

https://nixos.org/nixos/manual/

Manual has some section in it about installing emacs with selected
packages.  Let's give that a try.



build errors:

output path ‘/nix/store/1ii1lnwpgpgrb3isc87f0b5f814z3wi6-frame-cmds.el’ has sha256 hash ‘143szv36bvcgrrima8ss1nn6v9s3lrlqbjf240lyx4mmv24lxds0’ when ‘05mdds242vcav9gy15phvlk9q8iy29wnc8bp0c7i6z6bblairfzj’ was expected

Mentioned here
https://github.com/NixOS/nixpkgs/issues/18934
that this might have problems with packages getting out-of-date.

Also mentioned to use 'use-package' in emacs, which should be able to
declaratively specify the packages except for the versions.  Might be
good enough.

https://github.com/jwiegley/use-package
So how to install that?

Also:
https://github.com/travisbhartwell/nix-emacs




[Reply][About]
[<<][nixos][>>][..]