[<<][buildroot][>>][..]
Sun Mar 25 18:06:10 EDT 2018

2018.02.x downgrading Erlang to 19.3

Make the trivial changes in package/erlang/erlang.mk
Download the tarball to the dl directory manually, and update erlang.hash

Maybe easier to go back in buildroot source and copy the old build dir.

https://github.com/buildroot/buildroot/tree/2017.11.x/package/erlang


Doing so creates failures:

tom@buildroot:~/exo/br/target/i586/build/erlang-19.3$ export PATH="/home/tom/exo/br/target/i586/host/bin:/home/tom/exo/br/target/i586/host/sbin:/home/tom/exo/br/target/i586/host/bin:/bin:/usr/bin:/sbin:/usr/sbin:/usr/local/bin:/usr/local/sbin"
tom@buildroot:~/exo/br/target/i586/build/erlang-19.3$ make cross_check_erl
* * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * *
* ERROR:   No usable Erlang/OTP system for the build machine found! Cannot
*          cross compile without such a system.
*
*          Either build a bootstrap system for the build machine, or provide
*          an Erlang/OTP-19 system in the $PATH, and try again. For more
*          information on cross compiling Erlang/OTP-19, see the
*          $ERL_TOP/xcomp/README file.
* * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * *
Makefile:343: recipe for target 'cross_check_erl' failed
make: *** [cross_check_erl] Error 1


Let's first rebuild the whole thing.  Might be some staile stuff.




[Reply][About]
[<<][buildroot][>>][..]