[<<][am335x][>>][..]
Sun Mar 11 10:38:12 EDT 2018

Buildroot


Problem: serial port config.  I need console access first.

dd if=/i/buildroot/home/tom/exo/br/target/bbb/images/sdcard.img


sdcard.img doesn't work.
the backup bootloader does start.

maybe instead of using sd card, use network boot for now?

board_name=[A335PBGL] ...

I guess the question is: why doesn't the buildroot image boot out of
the box on PocketBeagle?

Skip this step?  Use the bootloader + /boot directory including kernel
from the debian image.  Just get it to work asap.

TODO: also copy /lib/firmware
TODO: mkdir dev run



U-Boot SPL 2017.09-00002-g0f3f1c7907 (Oct 09 2017 - 15:30:2
Trying to boot from MMC1


U-Boot 2017.09-00002-g0f3f1c7907 (Oct 09 2017 - 15:30:22 -0otloader-Builder-607

CPU  : AM335X-GP rev 2.1
I2C:   ready
DRAM:  512 MiB
No match for driver 'omap_hsmmc'
No match for driver 'omap_hsmmc'
Some drivers were not found
Reset Source: Power-on reset has occurred.
MMC:   OMAP SD/MMC: 0, OMAP SD/MMC: 1
Using default environment

Model: BeagleBoard.org PocketBeagle
<ethaddr> not set. Validating first E-fuse MAC
Net:   No ethernet found.
Press SPACE to abort autoboot in 2 seconds
board_name=[A335PBGL] ...
switch to partitions #0, OK
mmc0 is current device
SD/MMC found on device 0
** Bad device 0:2 0x82000000 **
** Bad device 0:2 0x82000000 **
switch to partitions #0, OK
mmc0 is current device
Scanning mmc 0:1...
gpio: pin 56 (gpio 56) value is 0
gpio: pin 55 (gpio 55) value is 0
gpio: pin 54 (gpio 54) value is 0
gpio: pin 53 (gpio 53) value is 1
switch to partitions #0, OK
mmc0 is current device
gpio: pin 54 (gpio 54) value is 1
Checking for: /uEnv.txt ...
Checking for: /boot.scr ...
Checking for: /boot/boot.scr ...
Checking for: /boot/uEnv.txt ...
gpio: pin 55 (gpio 55) value is 1
2045 bytes read in 17 ms (117.2 KiB/s)
Loaded environment from /boot/uEnv.txt
Checking if uname_r is set in /boot/uEnv.txt...
gpio: pin 56 (gpio 56) value is 1
Running uname_boot ...
loading /boot/vmlinuz-4.4.91-ti-r133 ...
8886912 bytes read in 579 ms (14.6 MiB/s)
loading /boot/dtbs/4.4.91-ti-r133/am335x-pocketbeagle.dtb ...
117513 bytes read in 69 ms (1.6 MiB/s)
uboot_overlays: [fdt_buffer=0x60000] ...
uboot_overlays: unable to find [mmc 0:1 /lib/firmware/AM335X-PRU-RPROC-4-4-TI-00A0.dtbo]...
loading /boot/initrd.img-4.4.91-ti-r133 ...
5416133 bytes read in 357 ms (14.5 MiB/s)
debug: [console=ttyO0,115200n8 root=/dev/mmcblk0p1 ro rootfstype=ext4 rootwait coherent_pool=1M net.ifnames=0 quiet] ...
debug: [bootz 0x82000000 0x88080000:52a4c5 0x88000000] ...
## Flattened Device Tree blob at 88000000
   Booting using the fdt blob at 0x88000000
   Loading Ramdisk to 8fad5000, end 8ffff4c5 ... OK
   Loading Device Tree to 8fab5000, end 8fad4b08 ... OK

Starting kernel ...

[    0.001715] clocksource_probe: no matching clocksources found
[    2.126777] wkup_m3_ipc 44e11324.wkup_m3_ipc: could not get rproc handle
[    2.285522] omap_voltage_late_init: Voltage driver support not added
[    2.293789] PM: Cannot get wkup_m3_ipc handle
[    2.816589] musb-hdrc musb-hdrc.1.auto: VBUS_ERROR in a_wait_vrise (80, <SessEnd), retry #3, port1 0008010c
mount: mounting /dev on /root/dev failed: No such file or directory
mount: mounting /dev on /root/dev failed: No such file or directory
mount: mounting /run on /root/run failed: No such file or directory
run-init: opening console: No such file or directory
Target filesystem doesn't have requested /sbin/init.
run-init: opening console: No such file or directory
run-init: opening console: No such file or directory
run-init: opening console: No such file or directory
run-init: opening console: No such file or directory
run-init: opening console: No such file or directory
No init found. Try passing init= bootarg.


BusyBox v1.22.1 (Debian 1:1.22.0-19+b3) built-in shell (ash)
Enter 'help' for a list of built-in commands.

(initramfs) 




[Reply][About]
[<<][am335x][>>][..]